Results 1 to 3 of 3

Thread: Ardashir Fort Crashing Issues

  1. #1

    Thumbs down Ardashir Fort Crashing Issues

    I tried to do Ardashir Fort, which I haven't done in many years but was unsuccessful due to crashing twice. One was at the point where players move backwards to fall into the water and the other where you can enter on the left side of the entrance, where I end up stuck in 'generating content' loading screens.

    (I also crash in Shadow of Vanaheim - Fort Storisbjorn in the location by the lake and where you collect fish every time).

    I play at high settings but tried to switch to RAID and PVP settings to see if anything changes but that didn't help either.

    Is there a way to fix these issues?
    ~*~ A real life Bear Shaman ~*~
    ~*~ ,,,>^O.O^<,,, Cimmerian women have claws like cats! ,,,>^O.O^<,,, ~*~

  2. #2


    I had similar issues when I first entered dungeons after I had to reinstall Windows.

    Especially this crashing once you try to jump down into the water pit, I fixed this by turning all settings manually down to the lowest (restart the game after you did that, then enter the dungeon), the crashing then was only a short freeze, the next time I entered I could go there with all settings turned to high and jump down, I still get the freeze every time but I do not crash anymore. Another thing you could do is not instantly jumping down, stand with your back to the edge and slowly turn the camera view ontop of you character, so that only you look down, whenever I do that the freeze appears but after that I can safely jump down there.

    For the door part, I am not sure what you could try to do there. Maybe use the fix data thing in the patcher once, or you could try to completely walk through the whole instance once, find someone with an empty instance, group up with him and talk a walk through the dungeon, maybe the game needs to completely load all parts at the first time before taking the shortcut, since that was a problem for me when I teleported to Shaulun in Chosain, I needed to walk through the whole playfield once (after the reinstalling of Windows and the game) so it could load everything slowly, next time I could safely use the teleport to Shaulun (probably had something to do with all the NPCs being loaded the first time at once which was causing problems).

    If none of this works, you could check the drivers for your graphics card, maybe they are outdated and need to be patched, but other that that I don't really know any more ways to fix these issues.
    Last edited by xCodename; 30th July 2017 at 14:35.

  3. #3


    I'm having the same crashing issues with Hellish Savages on Dead Man's Hand. I crash a lot too in graphics heavy environments like Northern Grasslands even with my video drivers updated. My AMD Radeon 6870 is now considered a Legacy device which doesn't help, I suppose...

    I'm hoping to get a brand new computer with a more recent video card in the next couple of months as my computer is a bit old and hopefully, that will solve my current issues.
    ~*~ A real life Bear Shaman ~*~
    ~*~ ,,,>^O.O^<,,, Cimmerian women have claws like cats! ,,,>^O.O^<,,, ~*~

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts