Results 1 to 3 of 3

Thread: Assertion Failed

  1. #1

    Default Assertion Failed

    I'm in a bit of a pickle.

    I've been playing the game without incident for a few days now, and I love it. So I decided to subscribe. After doing so, I closed down the game client and reopened it, hoping in doing so my membership benefits would kick in. No dice - instead, the game client crashes every time I try to open it. I get an error log titled 'Assertion Failed' with a bunch of techno-babble I don't understand. (There's a screengrab attached to this post for reference.)

    I've already tried the Repair Broken Data option on the start-up menu. It doesn't work. The same error recurs.

    Please don't tell me I paid, only to render my game unplayable.

    ADDT'L NOTE: I'm running the game on an HP Intel laptop circa 2009. Seriously, it still runs Windows 7. It's a dinosaur.
    Attached Images Attached Images
    Last edited by aprz91; 2nd September 2017 at 16:35.

  2. #2


    You can ask for slow help from Funcom customer service:

    I assume the "attempt to continue" button doesn't work?

    I think I once heard of this problem happening for people and being fixed by toggling between Windowed and Fullscreen modes.

    Also, is it the patcher crashing, or the game client itself after the patcher is all done and successful?

    Last ditch effort might be to uninstall the game and reinstall it again.

  3. #3


    To me it seems like the video card driver or some DX issue. Trying to guess over the internet is a long shot through a 8 year old laptop and I bet support won't help you.

    What video card is in it?
    Grandmaster Tos
    Rogue Angels
    Time Trial Vids

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts